MPC Video Renderer

Автор V0lt, 24 февраля 2018, 19:10:59

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Evgeniy1990

Aleksoid1978,
Цитировать
Просьба проверить переход в FSE и обратно(особенно первый запуск после включения системы) - https://yadi.sk/d/SCM6RQldFPEucQ
Небольшие переделки касаемо DX9, v0lt написал что первый запуск - виснет переход из FSE в окно.
Проверил переход из режима FSE обратно в окно. Действительно, после перезагрузки системы, или первом включении системы, после обратного перехода из FSE в окно, плеер виснет намертво. Подтверждаю!
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

V0lt

Evgeniy1990
Спасибо. Может подтвердить, что в 0.4.8.1364 из репозитория такого бага нет?

Aleksoid1978

Ок понял, как только будет возможность - проверю у себя.
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

V0lt,
Цитировать
Evgeniy1990
Спасибо. Может подтвердить, что в 0.4.8.1364 из репозитория такого бага нет?
Подтверждаю! Собрал и проверил Git v0.4.8.1364_git2020.06.22-2f1ee98. После перезагрузки системы, после выхода из режима FSE в окно, плеер не виснет. Обратный переход выполняется нормально.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Evgeniy1990

Aleksoid1978,
Цитировать
Ок понял, как только будет возможность - проверю у себя.
В вашем тестовом билде, после ваших переделок, при обратном переходе из FSE в окно, переход вроде как выполнился, но при этом сам FSE никуда не ушел. Отсюда и мертвое зависание. Это легко заметить и проверить с помощью поднесения курсора мышки.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

Перезалил - ссылка та же, была опечатка в коде :)
Проверяем.
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

Aleksoid1978,
Цитировать
Перезалил - ссылка та же, была опечатка в коде :)
Проверяем.
Проверил обновленный билд. Теперь порядок. Обратный переход из FSE в окно работает нормально.
Так и знал, что была где-то опечатка в коде. :) Это было очень хорошо заметно по поведению после выхода из FSE.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

Точно проверил именно после запуска системы первый раз ? А то у себя стал ловить зависон :)
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

Aleksoid1978,
Цитировать
Точно проверил именно после запуска системы первый раз ? А то у себя стал ловить зависон :)
Естественно! Ну, хорошо, щас еще раз перепроверю, вернусь "в начало времен".
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Evgeniy1990

Aleksoid1978,
Перепроверил ваш обновленный тестовый билд. При обратном переходе из FSE в окно, после перезагрузки системы, сам переход работает нормально, плеер не виснет. Я проверил на Windows 7. Странно. (о_О) Пошел проверять на Windows 10...
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

#1045
А я поймал еще один баг - если при FSE режиме сменить разрешение(того устройства где идет вывод FSE) воспроизведение идет, но сам проигрыватель висит.
Знаю даже почему - но не знаю как обойти :)
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

Aleksoid1978,
Цитировать
А я поймал еще один баг - если при FSE режиме сменить разрешение(того устройства где идет вывод FSE) воспроизведение идет, но сам проигрыватель висит.
Знаю даже почему - но не знаю как обойти :)
Это уже совсем другой баг, мне известно о нем. Вот только я проверяю пока "одномониторность" (работу на одном мониторе), а не мультимониторность.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

Да это другое, я просто отписался.
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

V0lt

#1048
MpcVideoRenderer64.ax от 09:50 [9631C87E] не завис после перезагрузки.

Aleksoid1978

Ну тогда я заливаю изменения ?
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /GTX 1650 /Samsung U28R550UQI /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215