1

Тема: Ошибка в H.264 DXVA декодере [Исправлено]

Сэмпл - https://www75.zippyshare.com/v/WdGU68oK/file.html
"Ошибка" на стороне ffmpeg, периодически(и только при использовании DXVA2), ffmpeg реинициализирует декодер.
В дебаг-выводе:

[h264 @ 0eb80000] Reinit context to 1280x720, pix_fmt: dxva2_vld

В софте все ок, LAV и в DXVA все ок. Попробовал методом тыка выяснить из-за чего - не вышло.

У кого есть время/желание методом перебора билдов. Пользак писал что это уже давно. Что самое интересное - переход на LAV Source исправляет ситуацию - причину я совсем не понял smile

I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

2 (изменено: Evgeniy1990, 2018-12-03 09:41:11)

Re: Ошибка в H.264 DXVA декодере [Исправлено]

Попробую поискать проблемное изменение в SVN методом перебора билдов.

Первоначальный диапазон поиска: [3252 -> 4234]
Текущий диапазон поиска:  [3252 -> 3513]

Продолжаю поиск...

[3252 -> 3355]
[3296 -> 3355]
[3296 -> 3326]
[3296 -> 3316]
[3296 -> 3310]

Окончательный диапазон поиска: [3296 -> 3303]

Добавлено: 2018-12-03 09:44:21

Aleksoid1978

Исходя из окончательного диапазона поиска, тут как минимум три сомнительных изменения в SVN, которые могли повлиять на декодирование в режиме DXVA2 данного видео файла.

Это SVN: 3300, 3302 и 3303.


Добавлено: 2018-12-03 09:52:57

Aleksoid1978

Итоговый диапазон поиска: [3302->3303]

Ура! Я смог точно найти проблемное изменение в SVN - это SVN r3303.
Именно оно и заставляет реинициализировать декодер.


Добавлено: 2018-12-03 09:54:40

Ха, если откатить изменения в SVN r3303, то данный видео файл воспроизводится нормально. smile
Следовательно - оно некорректное.


Добавлено: 2018-12-03 09:56:51

Рад был вам помочь с поиском. smile А данное изменение и правда довольно сомнительное. 
Пользователь был прав, данный баг присутствует уже очень давно.


Добавлено: 2018-12-03 10:06:55

Моя сборка SVN r3303 датируется 17-ым января этого 2018 года, как и ваше это изменение в SVN. ))

Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

3

Re: Ошибка в H.264 DXVA декодере [Исправлено]

Отлично - спасибо. Буду копать ))

I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

4

Re: Ошибка в H.264 DXVA декодере [Исправлено]

Aleksoid1978 пишет:

Отлично - спасибо. Буду копать ))

Пожалуйста. smile Я смотрю, вы уже исправили этот баг. Только один вопрос - а где это исправление? В SVN пока его нет, или надо подождать?

Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.