Автор Тема: Надпись "watch" при добавлении ссылок в плейлист [Исправлено]  (Прочитано 817 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Evgeniy1990

  • Ветеран
  • *****
  • Сообщений: 1379
Баг-поломка: при добавлении YouTube-ссылок в плейлист, все они имеют одно единственное название (имя) "watch", вместо своих оригинальных названий (имен).

Также, если запустить, или просто открыть любую YouTube-ссылку, то в конце названия видео файла добавляется автоматически сама по себе надпись "- YouTube".
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2130
Значит у тебя отключен встроенный парсер.
I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

  • Ветеран
  • *****
  • Сообщений: 1379
Цитата: Aleksoid1978
Значит у тебя отключен встроенный парсер.
А вот и неправда - включен как раз таки!

Добавлено: 2019-10-13 09:38:38

Aleksoid1978
Вот видеозапись.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2130
Да-да, что-то поломалось :)

Добавлено: 2019-10-13 16:51:54

Ха - что-то на стороне гугла, возможно что-то в API или связанное с API ключем. Позже гляну точнее :)


Добавлено: 2019-10-13 17:56:37

Исправил. Дальше посмотрим ...
I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

  • Ветеран
  • *****
  • Сообщений: 1379
Aleksoid1978

И снова возникла данная проблема. Неужели это глюк самого YouTube? Или же Google постоянно, или периодически меняет эти API-ключи?
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2130
Не знаю - проверил только что случайный ролик с Youtube, все ок.
I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215

Evgeniy1990

  • Ветеран
  • *****
  • Сообщений: 1379
Aleksoid1978

Интересно, что когда YouTube отдает "watch", он добавляется в сам плейлист и открывается.
А вот в случае с плейлистами, когда происходит этот, скажем так, - "глюк", в плейлист просто доавляется некий файл с названием "Playlist" и при этом не запускается. Плеер говорит: "Не удается воспроизвести файл", словно это и не плейлист вовсе.

Суть вот в чем:

Ожидание: - плейлист с кучей файлов с названием "watch".
Реальность: - файл с названием "Playlist" в плейлисте и с ответом плеера: "Не удается воспроизвести файл".

Я это написал к тому, что в случае такого "глюка", просто бесполезно будет копировать ссылки на плейлисты и открывать их в плеере, поскольку это будет некий "пустой" файл с названием "Playlist", а не сам плейлист со списком файлов.

Т.е. для плейлистов, в отличие от одиночных файлов, логика открытия, при наличии "глюка" не работает вообще.
Остается только лишь ждать, когда он исчезнет. А последнее время он проявляется довольно часто, чаще, чем было раньше.

Такое вот неудобство по вине YouTube, точнее самого Google.
Motherboards: ASUS P5Q/GIGABYTE EP35C-DS3R, CPU: Core 2 Duo E8300/E8400, Memory: DDR2/DDR3, Video: MSI GTX 465/ASUS EAH5770/GTX 650 Ti, Audio: ASUS Xonar DG 5.1/Creative SB 5.1. VX/X-Fi Xtreme Gamer.

Aleksoid1978

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2130
Ну и вот зачем каждый раз писать. Это чисто "прикол" google. Никакой плейер или программа в таком поведении не виновата.
I7 2600K@4.2 / Asrock P67 Extreme 4 Gen 3 / Kingston HyperX 8Gb 1866 (4x2) Kit / GIGABYTE GTX 960 / BenQ EW2430 / LG 47LM620T / Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215